• Пн
  • Вт
  • Ср
  • Чт
  • Пт
  • Сб
  • Вс

Android P не будет поддерживать старые приложения

Android P не будет поддерживать старые приложения

Приложения, изначально разработанные с использованием API Android 4.1 и более старых версий, не будут поддерживаться на устройствах под управлением Android P. Об этом сообщают участники программы предварительного тестирования, получившие доступ к дебютной сборке Developer Preview.

При попытке установить на устройство приложение, несовместимое с новой ОС, на экране появится уведомление с соответствующим содержанием: «Это приложение было создано для более ранней версии Android и может работать некорректно. Проверьте наличие обновлений или обратитесь к разработчику».

Android P не будет поддерживать старые приложения

На данный момент минимальная версия API, поддерживаемая Android P, имеет номер v17. Он соответствует Android 4.2 Jelly Bean. Если предупреждение о несовместимости не исчезнет в будущих сборках, это может означать, что Google решила провести ревизию в Google Play, освободив каталог от устаревших приложений.

Основная причина наметившейся зачистки магазина приложений заключается в желании Google заставить создателей ПО обновить его в соответствии с новыми требованиями к энергоэффективности. Например, добавить поддержку режима экономии энергии Doze, снижающего расход энергии.

Обсудить ограничение Android P можно в нашем официальном телеграм-чате.

Источник

Следующая новость
Предыдущая новость
Последние новости